Вы здесь

опять что то сломали! сегодня PHP и SQUIRRELMAIL заодно!

Warning: preg_replace() [function.preg-replace]: Internal pcre_fullinfo() error -3 in /1/var/www/localhost/htdocs/squirrelmail/functions/strings.php on line 261

Warning: preg_match() [function.preg-match]: Internal pcre_fullinfo() error -3 in /1/var/www/localhost/htdocs/squirrelmail/functions/i18n.php on line 150

Warning: Cannot modify header information - headers already sent by (output started at /1/var/www/localhost/htdocs/squirrelmail/functions/strings.php:261) in /1/var/www/localhost/htdocs/squirrelmail/functions/i18n.php on line 437

Warning: preg_replace() [function.preg-replace]: Internal pcre_fullinfo() error -3 in /1/var/www/localhost/htdocs/squirrelmail/functions/global.php on line 142

Warning: preg_replace() [function.preg-replace]: Internal pcre_fullinfo() error -3 in /1/var/www/localhost/htdocs/squirrelmail/functions/strings.php on line 261

Warning: Cannot modify header information - headers already sent by (output started at /1/var/www/localhost/htdocs/squirrelmail/functions/strings.php:261) in /1/var/www/localhost/htdocs/squirrelmail/src/login.php on line 115

[I] dev-lang/php
Available versions: (5) 5.2.6-r7 5.2.8-r1 5.2.8-r2
Installed versions: 5.2.8-r2(5)(17:26:13 02/16/09)(apache2 cgi cjk cli crypt curl debug flatfile gd gmp iconv mysql ncurses nls pcre reflection session sockets spell spl threads truetype unicode xml zlib -adabas -bcmath -berkdb -birdstep -bzip2 -calendar -cdb -concurrentmodphp -ctype -curlwrappers -db2 -dbase -dbmaker -discard-path -doc -empress -empress-bcs -esoob -exif -fastbuild -fdftk -filter -firebird -force-cgi-redirect -frontbase -ftp -gd-external -gdbm -hash -imap -inifile -interbase -iodbc -ipv6 -java-external -json -kerberos -kolab -ldap -ldap-sasl -libedit -mcve -mhash -msql -mssql -mysqli -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -posix -postgres -qdbm -readline -recode -sapdb -sharedext -sharedmem -simplexml -snmp -soap -solid -sqlite -ssl -suhosin -sybase -sybase-ct -sysvipc -tidy -tokenizer -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip -zip-external)

roundcube тоже не устанавливается!

похоже проблемы глобально в PHP

Warning: preg_replace() [function.preg-replace]: Internal pcre_fullinfo() error -3 in /1/var/www/localhost/htdocs/roundcube/program/include/iniset.php on line 92

Warning: include_once(.php) [function.include-once]: failed to open stream: No such file or directory in /1/var/www/localhost/htdocs/roundcube/program/include/iniset.php on line 93

Warning: include_once() [function.include]: Failed opening '.php' for inclusion (include_path='/var/www/localhost/htdocs/roundcube/:/var/www/localhost/htdocs/roundcube/program:/var/www/localhost/htdocs/roundcube/program/lib:/var/www/localhost/htdocs/roundcube/program/include:.:/usr/share/php5:/usr/share/php') in /1/var/www/localhost/htdocs/roundcube/program/include/iniset.php on line 93

Fatal error: Class 'PEAR' not found in /1/var/www/localhost/htdocs/roundcube/program/include/iniset.php on line 114

как-же оно все доссссстало!!!!! как ни обновление - так что то да ломается!!!

А ты что обновил?

—

-= Concordia victoriam gignit =-

да все обновлял, разьве теперь уследишь от чего сломалось (((
похоже это баг с PHP http://bugs.php.net/bug.php?id=31501
там как-то pcre не так стало работать
но решения то и нету (((( третий день почтовый сервер не работает ((((
как это все доссссстало... с этими бесконечными компиляциями... с вылавливанием очередных глюков багов и прочего, уже-б давно на дебиан бинарный перешел, да времени нет переносить все хозяйство (((((((

—

Наконец найден нетормозящий линукс для нетбуков

если так головотяпски подходить к апгрейду боевых серверов - тут ни дебьян ни суси ни что вообще кроме смены админа не поможет...

согласен, однако дело в удобстве обновления - неприятно когда нужно только и следить что бы оно не развалилось на ходу от случайного обновления.

да еще так фатально что бы неделю небыло никакого решения!!!!!
остается только откатить версии, ... как это не печально.

—

Наконец найден нетормозящий линукс для нетбуков

ну вот - откатил PHP до версии 5.2.6-r7 - все заработало... и что теперь - не обновлять больше никогда PHP ?

—

Наконец найден нетормозящий линукс для нетбуков

Перед обновлением серверов - особенно, если это нечто критичное и дорогое - нужно тестировать на специальной машине - никто нигде не гарантирует 100% совместимость всего софта с обновлениями - это просто невозможно.

Но обновляться никто и не заставляет, латание "дыр" производится иначе - через glsa

—

-= Concordia victoriam gignit =-

Так-то оно конечно так.

Но вот столкновение с реалиями жизни выдерживает... по моим наблюдениям только как исключение.
Мало у кого есть возможность построения стенда тождественного боевой конфигурации (причём даже в номинациях серьёзнее любого дата-центра).
А без этого тараканы не исключаются.

—

:wq
--
Live free or die

Но если у тебя нет возможности сделать тестовый стенд в реалиях твоего софта, которого, согласись, не так уж и много, то тем более такой возможности не будет у мейнтейнеров дерева - они не в состоянии отследить все комбинации пакетов и ориентируются на наши же отзывы от тех, кто сидит на нестабильной ветке. Народ вряд ли держит сервера на нестабильной - а речь идёт именно о сервере, куда чаще нестабильная применяется для сервера разработки или рабочей станции - где нужна какая-нить последняя фича. После слёта системы в результате отключения света в момент обновления - в один неподходящий момент посреди жаркого рабочего дня - я завязал с неплановыми обновлниями нашего сервака и стараюсь делать это только в крайних случаях, заранее подготовив и себя и народ ))

—

-= Concordia victoriam gignit =-

Блин а кто тебя просит постоянно компилировать что-то. Собрал систему, работает - не трогай, особенно если она важная, и ничего не обновляй если на то нет серьезных причин.

—

..................................................................
Unix - дружественная система, но своих друзей она хорошо выбирает.

помоему это проблема с PHP & BOM
http://newsboard.unclassified.de/docs/trouble#noheaders

Господа! Решение как мне кажется найдено:
http://forums.gentoo.org/viewtopic-t-723800-postdays-0-postorder-asc-start-25.html?sid=1ad999eef913ae7e0c9448d8162f9730
http://bugs.gentoo.org/256522
Сейчас у себя попробую апачь обновить, и отпишусь...

Решение помогло! Чего и вам желаю!