perl-core/perl проблема с зависимостями

Доброго времени суток, столкнулся с:

!!! The following binary packages have been ignored due to changed dependencies:

perl-core/File-Path-2.130.0::gentoo

Попробовал разрулить, но споткнулся на то, что в зависимостях пакеты требуют разные версии perl:

pi64 ~ # emerge --binpkg-changed-deps=y dev-lang/perl

Local copy of remote index is up-to-date and will be used.

Local copy of remote index is up-to-date and will be used.
Calculating dependencies... done!
[binary r U ] dev-lang/perl-5.26.2 [5.26.1-r1]
[binary r U ] dev-lang/perl-5.30.1 [5.26.1-r1]
[binary rR ] net-irc/irssi-1.2.2

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

(dev-lang/perl-5.30.1:0/5.30::gentoo, binary scheduled for merge) USE="berkdb gdbm -debug -doc -ithreads" pulled in by
=dev-lang/perl-5.30* required by (virtual/perl-File-Spec-3.780.0:0/0::gentoo, installed) USE=""
^ ^^^^^
dev-lang/perl:0/5.30= required by (dev-perl/Try-Tiny-0.300.0:0/0::gentoo, installed) USE="-minimal -test"
^^^^^^^^
(and 89 more with the same problems)

(dev-lang/perl-5.26.2:0/5.26::gentoo, binary scheduled for merge) USE="berkdb gdbm -debug -doc -ithreads" pulled in by
dev-lang/perl:0/5.26= required by (perl-core/File-Path-2.130.0:0/0::gentoo, installed) USE=""
^^^^^^^^
(and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

(perl-core/File-Path-2.130.0:0/0::gentoo, installed): ebuild is masked or unavailable

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Подскажите как это можно правильно разрулить?

Читали?https://wiki.gentoo.o

Поискали тут на форуме хотя

Поискали тут на форуме хотя бы для сначала... я тут уже не раз это объяснял!
Посмотри тут - возможно кое-что устарело, но концепция должна быть понятна.

!

Устаревание элементов иногда роялит.
В последнее обновление перла, насколько я помню, дэвы утверждали, что perl-cleaner не требуется.
И оно вполне подтвердилось моей практикой.

:wq
--
Live free or die

SysA написал(а):Поискали тут

SysA написал(а):
Поискали тут на форуме хотя бы для сначала... я тут уже не раз это объяснял!
Посмотри тут - возможно кое-что устарело, но концепция должна быть понятна.

Концепция понятна и сделано по концепции. Однако, после

emerge -1 --nodeps perl perl-cleaner
perl-cleaner --reallyall

perl обновляется с версии 5.26 на 5.30. Дальше при попытке emerge -v --binpkg-changed-deps=y perl-core/File-Path нарываюсь на блок virtual/perl-File-Path, делаю ему --unmerge, повторяю предыдущую команду, только теперь он предлагает сделать даунгрейд perl до 5.26 т.к perl-core/File-Path не поддерживает perl 5.30

(dev-lang/perl-5.26.2:0/5.26::gentoo, binary scheduled for merge) USE="berkdb gdbm -debug -doc -ithreads" pulled in by
dev-lang/perl:0/5.26= required by (perl-core/File-Path-2.130.0:0/0::gentoo, binary scheduled for merge) USE=""
^^^^^^^^

а при даунгрейде некоторые зависимости требуют версию 5.30 и опять блок. К как всё это безобразие разрулить я так вот и не понял

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".