SAMBA

Всем здравствуйте.
я с Gentoo общаюсь относительно недавно.
пытаюсь установить с нуля сервак и сразу стопор - не могу поставить samba.
вот вывод ermerge -av net-fs/samba

R19FTP2 ~ # emerge -av samba

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: 5 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libaio-0.3.110::gentoo  USE="-static-libs {-test}" ABI_X86="(64) -32 (-x32)" 42 KiB
[ebuild  N     ] dev-util/cppunit-1.13.2-r2::gentoo  USE="-doc -examples -static-libs" ABI_X86="(64) -32 (-x32)" 932 KiB
[ebuild  N     ] dev-db/lmdb-0.9.18:0/0.9.18::gentoo  USE="-static-libs" 136 KiB
[ebuild  N     ] dev-libs/libbsd-0.8.3::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 349 KiB
[ebuild  N     ] sys-apps/keyutils-1.5.9-r1::gentoo  USE="{-test}" ABI_X86="(64) -32 (-x32)" 73 KiB
[ebuild  N     ] dev-python/mimeparse-0.1.4-r1::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 6 KiB
[ebuild  N     ] dev-python/six-1.10.0::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 29 KiB
[ebuild  N     ] dev-python/pbr-1.10.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 109 KiB
[ebuild  N     ] dev-python/extras-0.0.3::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 7 KiB
[ebuild  N     ] dev-python/linecache2-1.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 11 KiB
[ebuild  N     ] dev-python/traceback2-1.4.0::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 16 KiB
[ebuild  N     ] dev-python/unittest2-1.1.0::gentoo  PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 80 KiB
[ebuild  N     ] dev-python/testtools-1.8.0::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 204 KiB
[ebuild  N     ] sys-libs/libcap-2.24-r2::gentoo  USE="pam -static-libs" ABI_X86="(64) -32 (-x32)" 62 KiB
[ebuild   R    ] sys-libs/tdb-1.3.13::gentoo  USE="python*" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ] app-arch/libarchive-3.3.1:0/13::gentoo  USE="acl bzip2 e2fsprogs iconv lzma threads xattr zlib -expat (-libressl) -lz4 -lzo -nettle -static-libs" ABI_X86="(64) -32 (-x32)" 6075 KiB
[ebuild  N     ] dev-libs/check-0.9.11::gentoo  USE="-static-libs -subunit" ABI_X86="(64) -32 (-x32)" 675 KiB
[ebuild  N     ] dev-libs/libev-4.23::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 512 KiB
[ebuild  N     ] dev-libs/libverto-0.2.5-r1::gentoo  USE="libev threads -glib -libevent -static-libs -tevent" ABI_X86="(64) -32 (-x32)" 342 KiB
[ebuild  N     ] app-crypt/mit-krb5-1.14.2::gentoo  USE="keyutils pkinit threads -doc (-libressl) -openldap (-selinux) {-test} -xinetd" ABI_X86="(64) -32 (-x32)" 11978 KiB
[ebuild  N     ] dev-python/subunit-1.2.0-r1::gentoo  USE="-static-libs {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 (-pypy) (-pypy3) (-python3_5) (-python3_6)" 450 KiB
[ebuild  N     ] net-nds/openldap-2.4.44::gentoo  USE="berkdb crypt ipv6 ssl syslog tcpd -cxx -debug -experimental -gnutls -iodbc -kerberos -kinit (-libressl) -minimal -odbc -overlays -perl -samba -sasl (-selinux) -slp -smbkrb5passwd -static-libs" ABI_X86="(64) -32 (-x32)" 5539 KiB
[ebuild   R    ] sys-libs/tevent-0.9.31-r1::gentoo  USE="python*" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ] sys-libs/ldb-1.1.29-r1:0/1.1.29::gentoo  USE="ldap python -doc" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 1248 KiB
[ebuild  N     ] net-fs/samba-4.5.10::gentoo  USE="acl pam system-mitkrb5 -addc -addns -ads -client -cluster -cups -dmapi -fam -gnutls -gpg -iprint -ldap -quota (-selinux) -syslog (-system-heimdal) -systemd {-test} -winbind -zeroconf" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 20504 KiB

Total: 25 packages (23 new, 2 reinstalls), Size of downloads: 49369 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-libs/ldb-1.1.29-r1::gentoo
# required by net-fs/samba-4.5.10::gentoo
# required by samba (argument)
>=sys-libs/tdb-1.3.13 python
# required by sys-libs/ldb-1.1.29-r1::gentoo
# required by net-fs/samba-4.5.10::gentoo
# required by samba (argument)
>=sys-libs/tevent-0.9.31-r1 python

Would you like to add these changes to your config files? [Yes/No] n

!!! All ebuilds that could satisfy ">=sys-libs/tdb-1.3.10[python,python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/tdb-1.3.13::gentoo (masked by: )
- sys-libs/tdb-1.3.12::gentoo (masked by: ~amd64 keyword)

(dependency required by "net-fs/samba-4.5.10::gentoo" [ebuild])
(dependency required by "samba" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

прошу помощи.

.

Первое замечание общеорганизационного плана:
1. Новости читать кто будет?
2. И приводить конфиги в соответствие с текущей конфигурацией?

:wq
--
Live free or die

Тут же тебе детально

Тут же тебе подробно объяснили, что делать:

NINJA2121 написал(а):
...
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by sys-libs/ldb-1.1.29-r1::gentoo
# required by net-fs/samba-4.5.10::gentoo
# required by samba (argument)
>=sys-libs/tdb-1.3.13 python
# required by sys-libs/ldb-1.1.29-r1::gentoo
# required by net-fs/samba-4.5.10::gentoo
# required by samba (argument)
>=sys-libs/tevent-0.9.31-r1 python

Would you like to add these changes to your config files? [Yes/No] n

!!! All ebuilds that could satisfy ">=sys-libs/tdb-1.3.10[python,python_targets_python2_7(-)?,-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),python_single_target_python2_7(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/tdb-1.3.13::gentoo (masked by: )
- sys-libs/tdb-1.3.12::gentoo (masked by: ~amd64 keyword)

(dependency required by "net-fs/samba-4.5.10::gentoo" [ebuild])
(dependency required by "samba" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".