Установка Skype на Gentoo

Пытаюсь установить Skype. Подскажите что сделать, чтобы он все таки установился. Разного рода дискуссии на тему звуковых драйверов мне не интересны, главное чтобы он установился и работал. На системе установлен KDE. Выдает такой вот лог:

нажать Y

нажать Y

Спасибо, но после этого

Спасибо, но после этого установка не начинается, выбрасывает обратно в терминал.

Чем не устраивает

Чем не устраивает http://web.skype.com/

?

Или хочется захламить систему поскорее?!

Лично у меня этот вебскайп

Лично у меня этот вебскайп тупо не работает. Сообщения проходят, а звонки делать не даёт.

Чем больше юзерфрендли, тем сложнее юзать.

Собирал с поддержкой apulse,

Собирал с поддержкой apulse, ситуация аналогичная.

А что мешает выполнить то,

А что мешает выполнить то, что прямо в этом логе прямым текстом и просят?

etc-update

Portage требовал собрать qtwebkit без поддержки исключений (отключив юз флаг exceptions).
После того как вы нажали "Y", были подготовлены соответствующие изменения для конфига.
Теперь надо выполнить "etc-update" и тем самым слить данное изменение со своим конфигом юз-флагов /etc/portage/package.use
Затем снова выполните "emerge -av net-im/skype" чтобы установить skype.

Обратите внимание, вначале лога есть предупреждение о том, что требуется обновить (слить изменения или отменить) для ещё 34 файлов в /etc/portage, которые у вас накопились за время пользования системой.

P.S. Также вы могли бы попытаться использовать неофициальный клиент skype web https://github.com/haskellcamargo/skype-unofficial-client, насколько я знаю, на данный момент они уже поддерживают аудио.

Судя по приведённому логу,

Судя по приведённому логу, пользоваться etc-update и eselect news топикстартер ещё не научился, раз столько накопиться успело. Или просто не читает логи, даже несмотря на метку IMPORTANT.

создай файл

создай файл /etc/portage/package.use/dev-qt или /etc/portage/package.use/for_skype
и добавь в него
>=dev-qt/qtwebkit-4.8.6-r1:4 -exceptions
и посмотри что будет дальше.

Гетто-скайп, мда, ну и

Гетто-скайп, мда, ну и название.

Всем спасибо, создал файл:

Всем спасибо, создал файл: /etc/portage/package.use/qtwenbkit и прописал: >=dev-qt/qtwebkit-4.8.6-r1:4 -exceptions
Все успешно скачалось и установилось.

Не только dev-qt/qtwebkit:4

Не только dev-qt/qtwebkit:4 -exception, но и dev-qt/qtgui:4 -egl

[I] dev-qt/qtgui
     Доступные версии:
     (4)    4.8.6-r4 (~)4.8.7
     (5)    5.5.1-r1^t 5.6.1(5/5.6)^t **5.6.9999(5/5.6)[1] {M}(~)5.7.0(5/5.7)^t **5.7.9999(5/5.7)[1] **5.8.9999(5/5.8)[1] **5.9999(5/5.9999)[1]
       {(+)accessibility aqua cups dbus debug egl eglfs evdev +exceptions +gif gles2 +glib gtk gtkstyle ibus jpeg libinput mng nas nis pch +png qt3support test tiff trace tslib tuio +udev +xcb xinerama +xv ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Установленные версии:  4.8.7(4)(14:43:55 26.08.2016)(accessibility cups exceptions glib mng pch qt3support tiff xinerama xv -aqua -debug -egl -gtkstyle -nas -nis -trace ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32") 5.7.0(5)^t[1](16:38:35 27.06.2016)(dbus egl eglfs evdev gif gles2 jpeg libinput png tslib tuio udev xcb -accessibility -debug -gtk -ibus -test)

в таком виде работает

P.S.: Linux - это красная таблетка :-) Windows - синяя...

у меня так, и все

у меня так, и все работает

[ebuild R ] dev-qt/qtgui-4.8.6-r4:4::gentoo USE="accessibility cups egl exceptions glib mng qt3support tiff trace xinerama xv (-aqua) -debug -gtkstyle -nas -nis -pch" ABI_X86="32 (64) (-x32)" 236 011 KiB
[ebuild R ] dev-qt/qtwebkit-4.8.6-r1:4::gentoo USE="exceptions gstreamer icu jit (-aqua) -debug -pch" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild R ~] net-im/skype-4.3.0.37-r5::gentoo USE="plasma pulseaudio -apulse -pax_kernel (-selinux)" 18 859 KiB

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".