Вышел Calculate Linux 11.0

Вышла новая версия дистрибутива Calculate Linux 11.0. Доступны для загрузки шесть редакций дистрибутива под архитектуры i686 и x86_64: Calculate Linux Desktop с рабочим столом KDE (CLD), GNOME (CLDG) и XFCE (CLDX), Calculate Linux Scratch (CLS), Calculate Directory Server (CDS) и Calculate Scratch Server (CSS).

Основные изменения

  • Добавлены бинарные репозитории для Calculate Linux Desktop (CLD, CLDG and CLDX) и Calculate Directory Server (CDS) с поддержкой rolling-release (непрерывного цикла обновлений).
  • Доступен новый минималистичный дистрибутив Calculate Scratch Server (CSS).
  • Добавлен новый пакет calculate-assemble для сборки системы.
  • Доступны еженедельные сборки дистрибутивов.
  • Оптимизирован интерфейс пользователя в Calculate Linux Desktop.
  • Добавлена поддержка совмещенного хранения профиля пользователя для различных версий Calculate Linux Desktop (CLD, CLDG и CLDX).
  • Улучшена поддержка нетбуков.
  • Добавлена поддержка принтеров Canon.
  • Переход на Portage 2.2.
  • Calculate Directory Server теперь включает новый установщик cl-install.
  • При установке, разделы по умолчанию обозначаются через UUID.
  • Переход на использование KMS для видеокарт Intel.

Состав версий

  • CLD (KDE Desktop):
    KDE 4.5.5, Amarok 2.3.2, digiKam 1.7.0, Chromium 8.0.552.237, Kernel 2.6.36.2, OpenOffice 3.2.1, X.Org 7.4
    i686 - 1.9 GB, x86_64 - 2.0 GB
  • CLDG (GNOME Desktop):
    Gnome 2.30, Gimp 2.6.8, Chromium 8.0.552.237, Kernel 2.6.36.2, OpenOffice 3.2.1, X.Org 7.4
    i686 - 1.5 GB, x86_64 - 1.6 GB
  • CLDX (XFCE Desktop):
    XFCE 4.8, Gimp 2.6.8, Kernel 2.6.36.2, Chromium 8.0.552.237, OpenOffice 3.2.1, X.Org 7.4
    i686 - 1.3 GB, x86_64 - 1.4 GB
  • CLS (Scratch Desktop):
    X.Org 7.4, Kernel 2.6.36.2
    i686 - 465 MB, x86_64 - 507 MB
  • CDS (Directory Server):
    Bind 9.7.2-P3, Kernel 2.6.32.27, OpenLDAP 2.4.23, Postfix 2.7.1, ProFTPD 1.3.3d, Samba 3.5.6
    i686 - 641 MB, x86_64 - 690 MB
  • CSS (Scratch Server):
    Kernel 2.6.36.2
    i686 - 359 MB, x86_64 - 398 MB

Обновление
Обновить предыдущую версию Calculate Linux можно двумя способами:

  • Для обновления Calculate Linux 10.9 установите мета-пакет app-misc/calculate-meta. Для обновления более ранних версий, в конце выполните команду 'cl-install --live'.
  • Загрузите ISO образ в директорию /var/calculate/linux, после чего выполните команду 'cl-install -d /dev/sdaX', с указанием свободного раздела для установки. Установка займет 5-7 минут, большинство установок будут перенесены.

Ссылки
Сайт проекта: http://www.calculate-linux.ru
Загрузить: http://www.calculate-linux.ru/main/ru/download

?

Porteg 2.2 уже настолько стабильный, что уже вошел туда, вроде пока как альфа считается?

Если правильно помню уже, с

Если правильно помню уже, с год сижу на 2.2 и никаких проблем с ним не было, да причина маскировки была - нужны "тестеры" для ветки 2.1 .

Вопрос по теме

В старой версии portage был файл package.use туда я прописывал зависимости для пакетов, в новой версии это стало каталогом, так вот что должно лежать внути каталога что бы зависимости отрабатывались как в старой версии примерчик названия файла и содержимого, либо все валить в make.conf

man portage

man portage

Сколько угодно файлов с

Сколько угодно файлов с любыми именами. Формат файлов сохранился. И кстати в 11.0 по умолчанию стоит бинарный профиль, если меняете флаги, используйте при обновлении всегда опцию -N (--newuse).

Шаблоны

В бетта версии был косяк: после установки файрфокса 4.0_beta9_pre из оверлея mozilla нельзя было сделать вход в систему - вход происходил, но какой-то шаблон не мог наложиться на конфиги файрфокса, и выдвал стрёмное окошко с сообщением об ошибки(что-то там про firefox-3.5).

Вопрос: почему блокируется вход в систему из-за невозможности наложить шаблон(глупость же =) ).
И второй: может сделать окошки об ошибках по-симпотичней?
И предложение: может вообще не надо _каждый_раз_ накладывать шаблоны, если комп не введён в домен и используется одним человеком?

>Вопрос: почему блокируется

>Вопрос: почему блокируется вход в систему из-за невозможности наложить шаблон(глупость же =) ).

Сам факт что шаблон не может наложиться уже проблема. Ведь настраиваться может не только сеанс, но и службы сервера.

>И второй: может сделать окошки об ошибках по-симпотичней?

Я за то, чтобы этого окошка вообще не видеть.

>И предложение: может вообще не надо _каждый_раз_ накладывать шаблоны, если комп не введён в домен и используется одним человеком?

Шаблоны давно уже настраивают не дистрибутив, а пакет. Пакет может и не входить в базовый набор дистрибутива. Но после установки он получит те же настройки (шрифты, пути и т.д.). Причем даже если в этот момент Вы будете в сеансе. Это удобно.

При обновлении программы, могут смениться пути к настройкам. Шаблоны могут это поправить и гладко выполнить переход.

Это далеко не все преимущества.

Обновление можно отключить, изменив параметр update в файле ~/.calculate/ini.env. В этом случае сканирование будет происходить заметно быстрее.

А можно ли вообще отключить

А можно ли вообще отключить нахрен это сканирование? Чес слово, достало уже... От ввода логина до рабочего стола проходит 3 минуты

Скрипты входа и выхода

Скрипты входа и выхода находятся здесь:
/usr/share/calculate/xdm/login.d/
/usr/share/calculate/xdm/logout.d/

И после emerge -u world они

И после emerge -u world они не восстановятся?

>И после emerge -u world они

>И после emerge -u world они не восстановятся?

Чего-то я торможу. Выполните:
cl-desktop --uninstall

Хорошая версия, спасибо

Хорошая версия, спасибо

Скажите пожалуйста, а как его

Скажите пожалуйста, а как его можно поставить не с диска, а из линукс. Нет возможности загрузиться с CD, или флешки.

Если у Вас Gentoo Linux, то

Если у Вас Gentoo Linux, то подключите оверлей calculate (layman -a calculate) и установите пакет calculate-install. Затем образ нужно будет скопировать в /var/calculate/linux и выполнить "cl-install -s CLD ..." (если образ CLD).

Спасибо, поставил CLDX, но

Спасибо, поставил CLDX, но так и не смог побороть видеокарту sis 630/730, а в режиме Vesa видео к сожалению не проигрывается.
Собсно у меня задача найти дистр для ноута ребенку, ноут celeron 1,2Mhz, 256 Ram, звук sis, video sis 630/730, hdd 40G, cd-rom сломан, но есть флопик. У меня на моем рабочем компе DVD накрывается, пишет только cd. Но зато есть роутер на gentoo, с его помощью и ставил. На ноуте hdd ide, а у меня как раз ZIV ide, ноут умеет загрузку только с cd или hdd.

Заодно поставил на ноут CMC(делал по вашему ману два раздела, один с системой, один для обновления, вот и решил на пустующий поставить) но там таже беда. Перед CLDX пробовал usb-flash-usb-stage4, таже беда с видюхой, вместо видео синие окно mplayer, на CLDX черное.

Sis не настраивается, но сам

Sis не настраивается, но сам драйвер есть. Попробуйте сформировать xorg.conf. Поддержку можно добавить, если Вы пришлете настройки, т.к. карточки sis 630/730 у нас нет.

Спасибо

Спасибо за ссылочки, буду устанавливать.

А в чем заключается

А в чем заключается улучшенная поддержка нетбуков?

Темы под все разрешения,

Темы под все разрешения, настройка кнопок для тех моделей что у нас были. В шаблонах теперь отдельная ветка под ноуты.

Как реализована поддержка переключаемых видеокарт

Хотелось бы узнать как обстоит дело в направлении переключаемых видеокарт, попробовал LiveDVD 11.0@KDE на Acer 4820TG, в принципе для работы достаточно и интеловской карты и эффекты не тупят, довольно шустро работает, но есть же еще и радеон в этой машинке. Гугление по данному вопросу ничего хорошего не принесло.

Где-то была статейка, вроде

Где-то была статейка, вроде как возможность переключения появилась, времени пока нет посмотреть.

Интересно

Там выкинули wicd ? В старой версии у меня не поднималась сеть, хотел поставить себе calculate на работу

Сейчас вместо wicd

Сейчас вместо wicd используется NetworkManager.

Елы-палы

а я уже поставил 10.4 версию. Не хотелось качать.
Это хорошо что нетворк-манагер...

вроде бы говорилось о

вроде бы говорилось о совместимости дистрибутива с gentoo.
Вот вопрос:
есть gentoo. добавил оверлей calculate.
Однако в профилях профили калькулейта не появились. Так и должно быть?
Как я понимаю, если установить бинарный профиль калькулейта и "обновить" систему - она должна стать актуальной версией калькулейта?

eselect видит профили только

eselect видит профили только в пределах дерева портежей. Чтобы он отобразил профили из Calculate, нужно его пропатчить. Патч накладывает profile.bashrc из оверлея. Т.е. вначале все же придется добавить символическую ссылку на профиль вручную. Выглядит примерно так:

/etc/make.profile -> ../var/lib/layman/calculate/profiles/calculate/desktop/CLD/amd64/binary

Подставьте путь в зависимости от профиля, архитектуры и дистрибутива.

После этого проверьте состояние флагов и переменных:

emerge --info

За настройку системы отвечают утилиты Calculate. Вы можете установить их и выполнить настройку:

emerge sys-apps/calculate-utilities
cl-install --live

Чтобы собрать все пакеты из выбранного дистрибутива, достаточно выполнить:

emerge -uDNa calculate-meta

Этот мета-пакет, в зависимости от выбранного профиля дистрибутива, установит необходимый набор ПО. Отключать зависимости можно при помощи флага CALCULATE.

Настройки просмотра комментариев

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".